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Generating an Automated Restructuring Commitment 
 
I. Contents of Zip File 
 

File Name Description 
RCTransmittal 10-05-04.xls Excel spreadsheet that will pull 

data from any model (version 4.33 
and higher) and where the PAE 
will input additional information 
not provided in the model to 
populate the restructuring 
commitment. 

MergeDoc 10-05-04.doc 
 

Word document to be used to 
generate Restructuring 
Commitment, which will pull 
information from the RC 
Transmittal file. 

Restructuring Commitment.doc 
 

Most recent version of the 
Restructuring Commitment, 
indicating which fields are to be 
populated by the PAE (will pull 
from the RC Transmittal) and 
guidance to PAEs on which 
paragraphs should be included 
(will be determined by the RC 
Transmittal).   

RC Special Conditions  Library of optional clauses for use 
by PAEs in completing Paragraph 
48 of the Restructuring 
Commitment. 

AutoRC_Instructions 10-05-04.doc 
AutoRC_Instructions 10-05-04.pdf 

Instructions for generating the 
Automated Restructuring 
Commitment (provided in MS 
Word and Adobe Acrobat format).  
These instructions cover four 
different versions of Microsoft 
Office:  Office 2000 (See page 2), 
Office 2002 (see Page 11), Office 
XP (see Page 18) and Office 2003 
(see Page 28). 
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II. The Automated Restructuring Commitment 
 

This tool is designed to facilitate the compilation of the OAHP 
Restructuring Commitment.  As with any automated tool, 
especially documents with legal implications, it is imperative that a 
thorough review of the completed product take place before the 
document is sent out for signature.  The Restructuring 
Commitment.doc file is a reference tool for verifying the content 
of the auto-generated Restructuring Commitment (RC).  The 
yellow and green highlighted fields indicate sections that are 
unique to each RC and should be reviewed against the final 
product to ensure the correct information is included in each RC.   
If a section in the RC Transmittal displays “Not Applicable” but it 
is actually pertinent to the transaction, the data in the underwriting 
model need to be modified. 
 
Additionally, it is essential for legal counsel to review the 
completed document after it is generated to be sure it meets OAHP 
and legal requirements before it is sent out for signature. 
 
There are four unique sets of instructions included below.  Section 
III below includes instructions for users working with Office 2000.  
Section IV provides instructions for Office 2002 beginning on 
page 11, Section V guides a user through Office XP beginning on 
page 18, and Section VI relates to Office 2003, which begins on 
page 28. 

 
III. Generating an Automated Restructuring Commitment in 

Office 2000 
 

A. To generate an automated Restructuring Commitment, follow 
these steps: 

 
1. Open the Underwriting Model for the transaction for which you are 

creating the Restructuring Commitment (RC).  The underwriting model 
must be at least version 4.33 to work with this automation and must 
remain open on your computer throughout the entire process. 

 
2. Open the RC Transmittal 10-05-04 MS Excel file to be used to collect 

the data for populating the RC.   



September 30, 2004 3

 
3. Click Enable Macros. 

 
 
 
 
 
 
 
 
 
 
 
 
4. Click Don’t Update or No (depending on which version of MS Excel you 

have installed) to link information. 
 
 
 
 
 
 
 
 
 
 
 

B. To link the RC Transmittal spreadsheet to the underwriting model, 
follow these steps: 

 
1. Click on the Model Import tab. 
 
 
 
 

 
 

2. Click Click here to begin RC link update button that is located in Row 3 
of the worksheet. 
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3. Click OK when the Update the Links for the RC dialog box displays. 

 
 
 
 
 
 
 
 

4. Pull down Edit menu.   
 

5. Click Links.   
 
 
 
 
 
 
 
 
 
 
 
 

6. Click Change Source. 
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7. Locate the model file using the Windows Explorer dialog box.  Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The Model Import page will populate.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

9. Click Click here to Complete RC link update button. 
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10.  Click OK when the Save the File with a New Name dialog box displays. 

 
 
 
 
 
 
 
 
 

11. Pull down the File menu.   
 

12. Click Save As.  Save the file with a new name (for example, “RC 
Transmittal Jerusalem 10-10-04.xls”). 

 
 

C. To populate data needed to generate Restructuring 
Commitment which is not contained in the Underwriting Model, 
follow these steps: 

 
1. Click on the User Input tab. 
 
 
 
 
 
 
2. Input data in all fields with red type.   
 

If the model indicates certain sections are not relevant for the 
particular transaction, they will display as “Not Applicable” on the 
Model Import and User Input page of the RC Transmittal.  Skip to 
the next section.   

 
If a section displays “Not Applicable” but it is actually 
pertinent to the transaction, the data in the underwriting 
model need to be modified. 
 

3. Click Save. 
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D. To merge the data from the RC Transmittal spreadsheet (for 

example, RC Transmittal Jerusalem 08-10-04.xls) into MS Word, 
follow these steps: 

 
1. Open Mergedoc 10-05-04.doc. 
 
2. If MS Word cannot locate your data source, and the Data Source dialog 

box displays, click Find Data Source. 
 
 
 
 
 
 
 
 

If the Data Source dialog box does not automatically display, 
you need to identify the source manually.  Follow steps a, b, 
and c to manually select the source document.  Otherwise, 
skip to #3 below. 

 
a. Pull down the Tools menu and click Mail Merge to locate 

your data source. 
 
b. Click Get Data.  

 
 
 
 
 
 
 
 
 
 
 
 

c. Click Open Data Source. 
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3. Use the Windows Explorer dialog box to locate the RC Transmittal 
spreadsheet.  At the bottom of the Windows Explorer dialog box, you will 
need to use the pull down menu to select All Files so that MS Excel files 
display on the list.   

 
 
 
 
 

 
4. Click on the file name. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
5. Click Open. 
 
6. If the macros dialog box displays, click Yes that this document is from a 

trusted source. 
 

7. The Named or Cell Range dialog box will display.  Click on MailMerge.   
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8. Click OK. 
 
9. Pull down the Tools menu. 

 
10. Click Mail Merge. 

 
 
 
 
 
 
 
 
 
 
 

 
 

11. Click Merge. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
12. Verify that the Merge to: dialog box displays New Document. 
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13. Click Merge. 

 
 
 
 
 
 
 
 
 
 
 

14. Pull down the File menu.   
 
15. Click Save As.  Save the file with a new name (for example, “RC Jerusalem 

10-10-04.doc”). 
 
 

Congratulations!  At the end of the process, the completed RC will display 
with all of the blanks filled in, all relevant paragraphs included, and all 
inapplicable material intentionally omitted.  Please remember to have legal 
counsel review the completed document before it is sent out for signature. 
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IV. Generating an Automated Restructuring Commitment in 
Office 2002 

 
A. To generate an automated Restructuring Commitment, follow 

these steps: 
 

1. Open the Underwriting Model for the transaction for which you are 
creating the Restructuring Commitment (RC).  The underwriting model 
must be at least version 4.33 to work with this automation and must 
remain open on your computer throughout the entire process. 

 
2. Open the RC Transmittal 10-05-04 MS Excel file to be used to collect 

the data for populating the RC.   
 

3. Click Enable Macros. 
 
 
 
 
 
 
 
 
 
 

4. Click Don’t Update or No (depending on which version of MS Excel you 
have installed) to link information. 

 
 
 
 
 
 
 
 
 

B. To link the RC Transmittal spreadsheet to the underwriting model, 
follow these steps: 

 
1. Click on the Model Import tab. 
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2. Click Click here to begin RC link update button. 
 
 
 
 
 
 
 
3. Click OK when the Update the Links for the RC dialog box displays. 
 
 
 
 
 
 
 
 
4. Pull down Edit menu.   
 
5. Click Links.   

 
 
 
 
 
 
 
 
 
 
 
 

6. Click Change Source. 
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7. Locate the model file using the Windows Explorer dialog box.  Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The Model Import page will populate.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

9. Click Click here to Complete RC link update button. 
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10.  Click OK when the Save the File with a New Name dialog box displays. 
 
 
 
 
 
 
 
 
 

11. Pull down the File menu.   
 

12. Click Save As.  Save the file with a new name (for example, “RC 
Transmittal Jerusalem 10-10-04.xls”). 

 
 

C. To populate data needed to generate Restructuring 
Commitment which is not contained in the Underwriting Model, 
follow these steps: 

 
1. Click on the User Input tab. 
 
 
 
 
 
 
2. Input data in all fields with red type.   
 

If the model indicates certain sections are not relevant for the 
particular transaction, they will display as “Not Applicable” on the 
Model Import and User Input page of the RC Transmittal.  Skip to 
the next section.   

 
If a section displays “Not Applicable” but it is actually 
pertinent to the transaction, the data in the underwriting 
model need to be modified. 
 

3. Click Save. 
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D. To merge the data from the RC Transmittal spreadsheet (for 

example, RC Transmittal Jerusalem 10-10-04.xls) into MS Word, 
follow these steps1: 

 
1. Open Mergedoc 10-05-04.doc.  The RC Transmittal you most recently 

linked to will launch automatically.  It can remain open in the background. 
 
2. Make sure the "Show Mail Merge toolbar" is enabled in your Letters and 

Mailings menu (under Tools). 
 

3. In the Mail Merge tool bar, click the icon that says Open Data Source.  
Hang your cursor over the icon to display its name. 

 
4. Click Browse. 

 
5. Select All Files from "Files of Type" drop down menu at the bottom of the 

Open Data Source dialog box. 
 

6. Locate the RC Transmittal that you saved for this property.  Click Open 
(or OK). 

 
7. Click on MS Excel Worksheets via DDE (*.xls) when the Confirm Data 

Source dialog box displays.  Click OK. 
 

 
 
 
 
 
 
 

 
 
 
 

8. If you are prompted to save changes to the RC Transmittal which opened 
when you launched the Mergedoc, click No.  Do not close the RC 
Transmittal that you created for the property you are currently working 
with. 

 
9. If the macros dialog box displays, click Yes that this document is from a 

trusted source. 
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10. If the Links dialog box displays, click No, you do not want to update the 
links. 

 
11. The Named or Cell Range dialog box will display.  Click on MailMerge.   

 
 
 
 
 
 
 
 
 
 
 
 
 

12. Click OK. 
 
13. Select Merge to New Document from the Mail Merge Tool bar, as shown 

below. 
 
 
 
 
 
 
 

14. When the Merge to New Document dialog box displays, select All, then 
click OK. 

 
 
 
 
 
 
 
 
 
 
15. Pull down the File menu.   
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16. Click Save As.  Save the file with a new name (for example, “RC 

Jerusalem 10-10-04.doc”). 
 
 

Congratulations!  At the end of the process, the completed RC will display 
with all of the blanks filled in, all relevant paragraphs included, and all 
inapplicable material intentionally omitted.  Please remember to have legal 
counsel review the completed document before it is sent out for signature. 
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V. Generating an Automated Restructuring Commitment in 
Office XP 

 
A. To generate an automated Restructuring Commitment, follow 

these steps: 
 

5. Open the Underwriting Model for the transaction for which you are 
creating the Restructuring Commitment (RC).  The underwriting model 
must be at least version 4.33 to work with this automation and must 
remain open on your computer throughout the entire process. 

 
6. Open the RC Transmittal 10-05-04 MS Excel file to be used to collect 

the data for populating the RC.   
 

7. Click Enable Macros. 
 
 
 
 
 
 
 
 
 
 

8. Click Don’t Update or No (depending on which version of MS Excel you 
have installed) to link information. 

 
 
 
 
 
 
 
 
 

B. To link the RC Transmittal spreadsheet to the underwriting model, 
follow these steps: 

 
1. Click on the Model Import tab. 
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2. Click Click here to begin RC link update button. 
 
 
 
 
 
 
 
3. Click OK when the Update the Links for the RC dialog box displays. 
 
 
 
 
 
 
 
 
4. Pull down Edit menu.   
 
5. Click Links.   

 
 
 
 
 
 
 
 
 
 
 
 

6. Click Change Source. 
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7. Locate the model file using the Windows Explorer dialog box.  Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The Model Import page will populate.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

9. Click Click here to Complete RC link update button. 
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10.  Click OK when the Save the File with a New Name dialog box displays. 
 
 
 
 
 
 
 
 
 

11. Pull down the File menu.   
 

12. Click Save As.  Save the file with a new name (for example, “RC 
Transmittal Jerusalem 10-10-04.xls”). 

 
 

C. To populate data needed to generate Restructuring 
Commitment which is not contained in the Underwriting Model, 
follow these steps: 

 
1. Click on the User Input tab. 
 
 
 
 
 
 
2. Input data in all fields with red type.   
 

If the model indicates certain sections are not relevant for the 
particular transaction, they will display as “Not Applicable” on the 
Model Import and User Input page of the RC Transmittal.  Skip to 
the next section.   

 
If a section displays “Not Applicable” but it is actually 
pertinent to the transaction, the data in the underwriting 
model need to be modified. 
 

3. Click Save. 
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D. To merge the data from the RC Transmittal spreadsheet (for 

example, RC Transmittal Jerusalem 10-10-04.xls) into MS Word, 
follow these steps2: 

 
1. Open a new blank document in MS Word. 
 
2. Pull down the Tools menu. 

 
3. Click on Letters and Mailings. 

 
4. Click on Show Mail Merge Tool Bar. 
 
5. Pull down the Tools menu and click Options. 

 
6. Click on the Compatibility tab, as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Select Microsoft Word 2002 from Recommended options for pull down 
menu.  

 
8. Click on the General tab. 
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9. Select Confirm Conversion at Open. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

10. Click OK. 
 

11. Open Mergedoc 10-05-04.doc. 
 

12. If MS Word cannot locate your data source, and the Data Source dialog 
box displays, click Find Data Source. 

 
 
 
 
 
 
 
 

If the Data Source dialog box does not automatically display, 
you need to identify the source manually.  Follow steps a, b, 
and c to manually select the source document.  Otherwise, 
skip to #3 below. 

 
a. Pull down the Tools menu and click Mail Merge to 

locate your data source. 
 

b. Click Get Data.  
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c. Click Open Data Source. 
 
 
 
 
 
 
 
 
 

13. Use the Windows Explorer dialog box to locate the RC Transmittal 
spreadsheet.  At the bottom of the Windows Explorer dialog box, you will 
need to use the pull down menu to select All data sources. 

 
14. Click on the file name. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
15. Click Open. 
 
16. Click on MS Excel Worksheets via DDE (*.xls) when the Confirm Data 

Source dialog box displays.  Click OK. 
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17. If the macros dialog box displays, click Yes that this document is from a 
trusted source. 

 
18. The Named or Cell Range dialog box will display.  Click on MailMerge.   

 
 
 
 
 
 
 
 
 
 
 
 
 

19. Click OK. 
 
20. Select Merge to New Document from the Mail Merge Tool bar, as shown 

below. 
 
 
 
 
 
 
 

21. When the Merge to New Document dialog box displays, select All, then 
click OK. 

 
 
 
 
 
 
 
 
 
 
 
22. Pull down the Tools menu. 
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23. Click Mail Merge. 

 
 
 
 
 
 
 
 
 
 
 

 
 

24. Click Merge. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

25. Verify that the Merge to: dialog box displays New Document. 
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26. Click Merge. 

 
 
 
 
 
 
 
 
 
 
 

27. Pull down the File menu.   
 

28. Click Save As.  Save the file with a new name (for example, “RC 
Jerusalem 10-10-04.doc”). 

 
 

Congratulations!  At the end of the process, the completed RC will display 
with all of the blanks filled in, all relevant paragraphs included, and all 
inapplicable material intentionally omitted.  Please remember to have legal 
counsel review the completed document before it is sent out for signature. 
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VI. Generating an Automated Restructuring Commitment in 
Office 2003 

 
A. To generate an automated Restructuring Commitment, follow 

these steps: 
 

1. Open the Underwriting Model for the transaction for which you are 
creating the Restructuring Commitment (RC).  The underwriting model 
must be at least version 4.33 to work with this automation and must 
remain open on your computer throughout the entire process. 

 
2. Open the RC Transmittal 10-05-04 MS Excel file to be used to collect 

the data for populating the RC.   
 

3. Click Enable Macros. 
 
 
 
 
 
 
 
 
 
 

4. Click Don’t Update or No (depending on which version of MS Excel you 
have installed) to link information. 

 
 
 
 
 
 
 
 
 

B. To link the RC Transmittal spreadsheet to the underwriting model, 
follow these steps: 

 
1. Click on the Model Import tab. 
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2. Click Click here to begin RC link update button. 
 
 
 
 
 
 
 
3. Click OK when the Update the Links for the RC dialog box displays. 
 
 
 
 
 
 
 
 
4. Pull down Edit menu.   
 
5. Click Links.   

 
 
 
 
 
 
 
 
 
 
 
 

6. Click Change Source. 
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7. Locate the model file using the Windows Explorer dialog box.  Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click OK.  The Model Import page will populate.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

9. Click Click here to Complete RC link update button. 
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10.  Click OK when the Save the File with a New Name dialog box displays. 
 
 
 
 
 
 
 
 
 

11. Pull down the File menu.   
 

12. Click Save As.  Save the file with a new name (for example, “RC 
Transmittal Jerusalem 10-10-04.xls”). 

 
 

C. To populate data needed to generate Restructuring 
Commitment which is not contained in the Underwriting Model, 
follow these steps: 

 
1. Click on the User Input tab. 
 
 
 
 
 
 
2. Input data in all fields with red type.   
 

If the model indicates certain sections are not relevant for the 
particular transaction, they will display as “Not Applicable” on the 
Model Import and User Input page of the RC Transmittal.  Skip to 
the next section.   

 
If a section displays “Not Applicable” but it is actually 
pertinent to the transaction, the data in the underwriting 
model need to be modified. 
 

3. Click Save. 
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D. To merge the data from the RC Transmittal spreadsheet (for 

example, RC Transmittal Jerusalem 10-10-04.xls) into MS Word, 
follow these steps: 

 
1. Open a new blank document in MS Word. 
 
2. Pull down the Tools menu and click Options. 

 
3. Click on the Compatibility tab, as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Select Microsoft Word 2002 from Recommended options for pull down 
menu.  

 
5. Click on the General tab. 
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6. Select Confirm Conversion at Open. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7. Click OK. 
 

8. Open Mergedoc 10-05-04.doc. 
 

9. Pull down the Tools Menu.  Click on Letters and Mailings.  Then click 
on Mail Merge.  The Mail Merge task pane will display as shown below. 
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10. Click through the steps at the bottom of the page until you reach Step 3, 

Select Recipients.  You may need to bypass Select Document Type and 
Starting Document.   

 
 
 
 
 
 

 
 
 
 
 

If you're prompted to choose whether you want the information from the 
data file to be merged again into the main document, click Yes. 
 
 
 
 
 
 
 
 

 
11. Click Use an existing list.  Then click Browse to locate the file. 
 
12. Use the Windows Explorer dialog box to locate the RC Transmittal 

spreadsheet.  At the bottom of the Windows Explorer dialog box, you will 
need to use the pull down menu to select All data sources. 

 
13. Click on the file name. 
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14. Click Open. 
 
15. Click on MS Excel Worksheets via DDE (*.xls) when the Confirm Data 

Source dialog box displays.  Click OK. 
 

 
 
 
 
 
 
 

 
 

16. If the macros dialog box displays, click Yes that this document is from a 
trusted source. 

 
17. The Named or Cell Range dialog box will display.  Click on MailMerge.   

 
 
 
 
 
 
 
 
 
 
 
 
 

18. Click OK. 
 
19. The Mail Merge Recipients dialog box will display.  It will show one 

line, with the data for your transaction.  The checkbox in the left hand 
column should be checked. 
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20. Click OK. 
 

21. Bypass Step 4, Write Your Letter, and click through to Step 5, Preview 
Your Letter.  After several seconds, the completed mail merge document 
will display with information from the transmittal. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
22. On the View menu, point to Toolbars, and then click Mail Merge.  

 
23. Click Main Document Setup .  

 
24. Click Normal Word document.  

 
25. Pull down the File menu.   
 
26. Click Save As.  Save the file with a new name (for example, “RC 

Jerusalem 10-10-04.doc”).   
 
 

Congratulations!  At the end of the process, the completed RC will display 
with all of the blanks filled in, all relevant paragraphs included, and all 
inapplicable material intentionally omitted.  Please remember to have legal 
counsel review the completed document before it is sent out for signature. 
 

 


