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1. Solution Information

Solution Name <Solution Name>

Solution Acronym <Solution Acronym>

O AT S| s i

Document Owner <Owner Name>

Primary Segment Sponsor <Primary Segment Sponsor Name>
Version/Release Number <Version/Release Number>

2. Document History

<Provide information on how the development and distribution of the Test Plan is controlled and tracked.
Use the table below to provide the version number, date, author, and a brief description of the reason for
creating the revised version.>

Version No. Date Author Revision Description
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Note to the Author

[This document is a template of a Test Plan document for a project. The template includes instructions to
the author, boilerplate text, and fields that should be replaced with the values specific to the project.

e Blue italicized text enclosed in square brackets ([text]) provides instructions to the document
author, or describes the intent, assumptions and context for content included in this document.

e Blue italicized text enclosed in angle brackets (<text>) indicates a field that should be replaced
with information specific to a particular project.

e Text and tables in black are provided as boilerplate examples of wording and formats that may be
used or modified as appropriate to a specific project. These are offered only as suggestions to
assist in developing project documents; they are not mandatory formats.

When using this template for your project document, it is recommended that you follow these steps:

1. Replace all text enclosed in angle brackets (e.g., <Project Name>) with the correct field values.
These angle brackets appear in both the body of the document and in headers and footers. To
customize fields in Microsoft Word (which display a gray background when selected):

a. Select File>Properties>Summary and fill in the Title field with the Document Name and
the Subject field with the Project Name.

b. Select File>Properties>Custom and fill in the Last Modified, Status, and Version fields
with the appropriate information for this document.

c. After you click OK to close the dialog box, update the fields throughout the document with
these values by selecting Edit>Select All (or Ctrl-A) and pressing F9. Alternatively, you
can update an individual field by clicking on it and pressing F9. This must be done
separately for Headers and Footers.

2. Modify boilerplate text as appropriate to the specific project.

3. To add any new sections to the document, ensure that the appropriate header and body text
styles are maintained. Styles used for the Section Headings are Heading 1, Heading 2 and
Heading 3. Style used for boilerplate text is Body Text.

4. To update the Table of Contents, right-click and select “Update field” and choose the option-
“Update entire table”

5. Before submission of the first draft of this document, delete this “Notes to the Author” page and all
instructions to the author, which appear throughout the document as blue italicized text enclosed
in square brackets.]
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NOTE: If project teams are using automated tools to track and document testing activities, it
is acceptable to substitute tool-generated test result reports if they meet the information
requirements of the PPM template.
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4. Introduction
4.1 Purpose
This <Project Name> Test Plan provides a summary of the results of test performed as outlined

within this document.

Page 5
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5. Resource Requirements

<Ildentify the equipment and personnel resources required to perform the testing identified within the
scope of this document.>

5.1 Testing Environment

<Describe the testing environment needed to test the components identified in this document. Include
names, locations, availability, and any specific configuration or version requirements of the identified
equipment.>

5.2 Other Testing Components

<List other components needed to support testing; these components are not part of the solution being
tested. Include testing programs/devices and programming aids as well as which components must run
in parallel with the new solution to achieve functionality.>

5.3 Personnel Roles and Responsibilities

<Ildentify the groups required to perform the tests successfully. Include any special requirements, such as
multiple-shift operation or key personnel.>

Role/Function Necessary Skills Responsibilities

(Experience, Tool Sets, Etc.)

Project manager

Test lead

Configuration manager

Quiality assurance team member

Database administrator

Enterprise architect

Network administrator

IT security specialist

User testers

Table 1 - Personnel Roles and Responsibilities

5.4 Testing Schedule

<Ildentify the schedule of all tests including milestones, reviews, and resources. Reference the Project
Schedule (WBS), if applicable.>

5.5 Staff Training

<Ildentify the types of training and personnel to be trained. Reference the Training Plan, if applicable.>

PPM Version 2.0 ® June 2014 Page 6
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6. Assumptions, Constraints, and Risks

6.1 Testing Assumptions
<Ildentify the assumptions made regarding the solution being tested. Include assumptions related to
items such as equipment availability, resource skills, code availability, and data availability.>

6.2 Testing Constraints
<Ildentify the constraints that affect the testing. Include constraints related to items such as availability

of equipment, trained staff, and compressed project schedule.>

6.3 Project-Level Testing Risks
<Ildentify the risks associated with the testing activities. Include a work around or mitigation plan for
each of the identified risks and document the risks within the Risk Management Log.>

Page 7
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7. Testing Approach

<Outline the overall approach for testing the system features. Describe the measures taken to ensure
that all aspects of the system are successfully tested and can be implemented. Document the content,
methodology, and progression of test activities.

For example:
e Will some unit and integration testing be done and then more development?

e |s a prototype being built that will be tested for usability before the releasable software is
developed?

Also, include plans for testing of documentation (e.g. installation instructions, User Manual, Operations
and Maintenance Manual, training artifacts)

Use Sections 4 and 5 in this document to provide a detailed description of the test approaches.

Note: Once the system/application satisfies all of the unit/system/integration and user acceptance
testing then it is ready for deployment activities, which involve submitting it for production to the HUD
Test Center. The HUD Test Center can be considered the front-end of the deployment process. In addition
to providing release documentation, the purpose and value of the Test Center’s testing is to assure that:

e The deployment will work in HUD-standard environment/configuration;
e The production installation instructions are complete and correct;

e The files to be deployed are available and correct.>

7.1 Methodology

<Describe the general methodology or testing strategy for each type of testing described in this Test
Plan.>

7.2 Test Progression/Order

<Describe the manner in which progression is made from one test to another, so the entire cycle is
completed.>

7.3 Test Milestones

<List the testing milestones. Refer to the Project Schedule if applicable.

Some key elements to consider in developing test milestones are:

e Readiness of the product to be tested

e Readiness of the test environment

e Readiness of the test team for a transition from final developmental testing to product testing
e Determination of product test execution completion criteria>

PPM Version 2.0 ® June 2014 Page 8
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7.4 Test Data

<Specify the test data to be used. Describe the source, volume, and frequency of the data. Also, describe
the manual or automated techniques that will be used for manipulating the test data into a form
suitable for evaluation, allowing comparison of the results that should be produced to those that are
actually produced.>

7.5 Recording Results

<Describe how the test results will be captured, recorded, stored, and communicated to all necessary
parties, for both passed and failed tests. Identify what artifacts will need to be produced because of the
testing activities, e.g. a testing matrix, test cases, defect log, incident/bug report. Also include the
process/steps needed when the item fails the test.>

7.6 Analyzing Results

<Describe how the test results will be analyzed or quantified. Include the pass/fail criteria and the
number of times the various tests should be executed to ensure accurate results.>

7.7 Defect Resolution

<Describe how the defects identified during the test execution steps will be recorded, reviewed, and
resolved. Identify the criteria for defining the severity and priority (urgency) of the defects and bugs as it
relates to the project deliverables. Also, include a process for reviewing and resolving the defects and
bugs.>
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8. Unit/System Testing

<Describe any specific requirements needed for unit/system testing to be performed (e.g.
hardware/software, staffing, skills training).>

8.1 Test Risks/Issues

<Describe the risks associated with testing the product and document specific Unit/System Testing risks
in the Risk Management Log. Also outline appropriate mitigation strategies and contingency plans.>

8.2 Items to Be Tested/Not Tested

<Describe the items/features/functions to be tested that are within the scope of this Test Plan. Include a
description of how they will be tested, when, by whom, and to what quality standards. Also include a
description of those items that the project team and project managers have agreed will not be tested.>

Items to Be Tested Test Description Test Responsibility

Date

Table 2 - Items Included in Unit/System Testing

Items Excluded from Testing Description

Table 3 - Items Excluded from Unit/System Testing

8.3 Regulatory/Mandate Criteria

<Describe any regulations or mandates that the system must be tested against.>

8.4 Test Pass/Fail Criteria

<Describe the criteria used to determine if a test item has passed or failed its test.>

8.5 Test Entry/Exit Criteria

<Describe the entry and exit criteria used to start testing and determine when to stop testing.>

8.6 Test Deliverables

<Describe the deliverables that will result from the testing process (e.g. documents, reports, charts).>

8.7 Test Suspension/Resumption Criteria

<Describe the suspension criteria used to suspend all or portions of testing. Also describe the resumption
criteria used to resume testing.>

PPM Version 2.0 ® June 2014 Page 10
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8.8 Test Environmental /Staffing/Training Needs
<Describe any specific requirements needed for the testing to be performed (e.g. hardware/software,

staffing, skills training).>
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9. User Acceptance Testing

<Describe any specific requirements needed for user acceptance testing to be performed (e.g.
hardware/software, staffing, skills training).>

9.1 Test Risks/Issues

<Describe the risks associated with product testing and document specific User Acceptance Testing risks
in the Risk Management Log. Also outline appropriate mitigation strategies and contingency plans.>

9.2 Items to Be Tested/Not Tested

<Describe the items/features/functions to be tested that are within the scope of this Test Plan. Include a
description of how they will be tested, when, by whom, and to what quality standards. Also, include a
description of those items that the project team and project managers have agreed will not be tested.>

Items to Be Tested Test Description Test Responsibility

Date

Table 4 - Items Included in User Acceptance Testing

Items Excluded from Testing Description

Table 5 - Items Excluded from User Acceptance Testing

9.3 Regulatory/Mandate Criteria

<Describe any regulations or mandates that the system must be tested against.>

9.4 Test Pass/Fail Criteria

<Describe the criteria used to determine if a test item has passed or failed its test.>

9.5 Test Entry/Exit Criteria

<Describe the entry and exit criteria used to start testing and determine when to stop testing.>

9.6 Test Deliverables

<Describe the deliverables that will result from the testing process (e.g. documents, reports, charts). >

9.7 Test Suspension/Resumption Criteria

<Describe the suspension criteria used to suspend all or portions of testing. Also describe the resumption
criteria used to resume testing.>
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9.8 Test Environmental /Staffing/Training Needs
<Describe any specific requirements needed for the testing to be performed (e.g. hardware/software,

staffing, skills training)>
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10. Other Testing

<Describe any specific requirements needed for other required types of testing (e.g. integration,
regression, functional, stress, security) to be performed (e.g. hardware/software, staffing, skills
training).>

10.1 Test Risks/Issues

<Describe the risks associated with product testing and document specific testing risks in the Risk
Management Log. Also outline appropriate mitigation strategies and contingency plans.>

10.2 Items to Be Tested/Not Tested

<Describe the items/features/functions to be tested that are within the scope of this Test Plan. Include a
description of how they will be tested, when, by whom, and to what quality standards. Also, include a
description of those items that the project team and project managers have agreed will not be tested.>

Items to Be Tested Test Description Test Responsibility
Date

Table 6 - Items Included in Other Required Testing

Items Excluded from Testing Description

Table 7 - Items Excluded from Other Required Testing

10.3 Regulatory/Mandate Criteria

<Describe any regulations or mandates that the system must be tested against.>

10.4 Test Pass/Fail Criteria

<Describe the criteria used to determine if a test item has passed or failed its test.>

10.5 Test Entry/Exit Criteria

<Describe the entry and exit criteria used to start testing and determine when to stop testing.>

10.6 Test Deliverables

<Describe the deliverables that will result from the testing process (e.g. documents, reports, charts). >

10.7 Test Suspension/Resumption Criteria

<Describe the suspension criteria used to suspend all or portions of testing. Also describe the resumption
criteria used to resume testing.>
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10.8 Test Environmental/Staffing/Training Needs
<Describe any specific requirements needed for the testing to be performed (e.g. hardware/software,
staffing, skills training)>
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11. Appendix A: References

<Insert the name, version number, description, and physical location of any documents referenced in this
document. Add rows to the table as necessary.>

Table 8 below summarizes the documents referenced in this document.

Document Name Description \ Location

<Document name and . .
. <Document description> <URL to where document is located>
version number>

Table 8 - Appendix A: References
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12. Appendix B: Key Terms

Table 9 below provides definitions and explanations for terms and acronyms relevant to the content
presented within this document.

Term Definition

[Insert Term]

<Provide definition of term and acronyms used in this document>

Table 9 - Appendix B: Key Terms

PPM Version 2.0 ® June 2014

Page 17



